$re = '/(?<! ) (?! )/m';
$str = '\'SYS W$_FIasdfLESTATXS TABLE PARTITION 0 \'';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;