re = /(?<! ) (?! )/m
str = '\'SYS W$_FIasdfLESTATXS TABLE PARTITION 0 \''
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result