import re
regex = re.compile(r"(?<! ) (?! )", flags=re.MULTILINE)
test_str = "'SYS W$_FIasdfLESTATXS TABLE PARTITION 0 '"
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)