# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.(?=.*[a-z].)(?=.*[A-Z].)(?=.*[0-9].)(?=.*[@#$,.].).{6,}$/0$1/mg;t' <<< "abA0@67
abA0@6
abA0@678
abA0at678
"