#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.(?=.*[a-z].)(?=.*[A-Z].)(?=.*[0-9].)(?=.*[@#$,.].).{6,}$"
Local $sString = "abA0@67" & @CRLF & _
"abA0@6" & @CRLF & _
"abA0@678" & @CRLF & _
"abA0at678" & @CRLF & _
""
Local $sSubst = "0$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)