const regex = /^.(?=.*[a-z].)(?=.*[A-Z].)(?=.*[0-9].)(?=.*[@#$,.].).{6,}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.(?=.*[a-z].)(?=.*[A-Z].)(?=.*[0-9].)(?=.*[@#$,.].).{6,}$', 'mg')
const str = `abA0@67
abA0@6
abA0@678
abA0at678
`;
const subst = `0$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);