$re = '/^.(?=.*[a-z].)(?=.*[A-Z].)(?=.*[0-9].)(?=.*[@#$,.].).{6,}$/m';
$str = 'abA0@67
abA0@6
abA0@678
abA0at678
';
$subst = "0$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;