use strict;
my $str = 'abA0@67
abA0@6
abA0@678
abA0at678
';
my $regex = qr/^.(?=.*[a-z].)(?=.*[A-Z].)(?=.*[0-9].)(?=.*[@#$,.].).{6,}$/mp;
my $subst = '0$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";