re = /^.(?=.*[a-z].)(?=.*[A-Z].)(?=.*[0-9].)(?=.*[@#$,.].).{6,}$/m
str = 'abA0@67
abA0@6
abA0@678
abA0at678
'
subst = '0$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result