using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""sid"":""(.+?)""";
string input = @"[Message 1]
0{""sid"":""1BdTy3e4-jfrVM67AAAR"",""upgrades"":[],""pingInterval"":25000,""pingTimeout"":60000}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}