import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"sid\":\"(.+?)\"";
final String string = "[Message 1]\n"
+ "0{\"sid\":\"1BdTy3e4-jfrVM67AAAR\",\"upgrades\":[],\"pingInterval\":25000,\"pingTimeout\":60000}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}