import Foundation
let pattern = #""sid":"(.+?)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[Message 1]
0{"sid":"1BdTy3e4-jfrVM67AAAR","upgrades":[],"pingInterval":25000,"pingTimeout":60000}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)