re = /"sid":"(.+?)"/
str = '[Message 1]
0{"sid":"1BdTy3e4-jfrVM67AAAR","upgrades":[],"pingInterval":25000,"pingTimeout":60000}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end