// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""sid":"(.+?)""#).unwrap();
let string = "[Message 1]
0{\"sid\":\"1BdTy3e4-jfrVM67AAAR\",\"upgrades\":[],\"pingInterval\":25000,\"pingTimeout\":60000}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}