const regex = /(?:http?:\/\/|https?:\/\/)?(?:www\.)?github\.com\/(?:\/*)([\w\-\.\/]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:http?:\\\/\\\/|https?:\\\/\\\/)?(?:www\\.)?github\\.com\\\/(?:\\\/*)([\\w\\-\\.\\\/]*)', 'gm')
const str = `https://github.com/Chocksy`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);