$re = '/(?:http?:\/\/|https?:\/\/)?(?:www\.)?github\.com\/(?:\/*)([\w\-\.\/]*)/m';
$str = 'https://github.com/Chocksy';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;