re = /(?:http?:\/\/|https?:\/\/)?(?:www\.)?github\.com\/(?:\/*)([\w\-\.\/]*)/m
str = 'https://github.com/Chocksy'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result