import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n";
final String string = "[info] Sikuli vision engine loaded.\n"
+ "[info] Windows utilities loaded.\n"
+ "[info] VDictProxy loaded.\n"
+ "The arguments are: ['E:/automation.sikuli/automation.py', '{\"command\":\"sel_medi\n"
+ "a\",\"value\":\"5X7_on_letter\"},{\"command\":\"sel_printer\",\"value\":\"cutepdf\"},{\"comman\n"
+ "d\":\"sel_tray\",\"value\":\"formsource\"},{\"command\":\"print\",\"value\":\"print\"}']\n"
+ "5X7_on_letter not Selected";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}