// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\n").unwrap();
let string = "[info] Sikuli vision engine loaded.
[info] Windows utilities loaded.
[info] VDictProxy loaded.
The arguments are: ['E:/automation.sikuli/automation.py', '{\"command\":\"sel_medi
a\",\"value\":\"5X7_on_letter\"},{\"command\":\"sel_printer\",\"value\":\"cutepdf\"},{\"comman
d\":\"sel_tray\",\"value\":\"formsource\"},{\"command\":\"print\",\"value\":\"print\"}']
5X7_on_letter not Selected";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}