# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\n"
test_str = ("[info] Sikuli vision engine loaded.\n"
"[info] Windows utilities loaded.\n"
"[info] VDictProxy loaded.\n"
"The arguments are: ['E:/automation.sikuli/automation.py', '{\"command\":\"sel_medi\n"
"a\",\"value\":\"5X7_on_letter\"},{\"command\":\"sel_printer\",\"value\":\"cutepdf\"},{\"comman\n"
"d\":\"sel_tray\",\"value\":\"formsource\"},{\"command\":\"print\",\"value\":\"print\"}']\n"
"5X7_on_letter not Selected")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.