#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:.*[a-zA-Z])+)([a-zA-Z\d]{10,30})$"
Local $sString = "1eeeeeeeee333e" & @CRLF & _
"eeeeeeeee333e" & @CRLF & _
"2222222222222" & @CRLF & _
"622222222522" & @CRLF & _
"123456789012q"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")