$re = '/^(?=(?:.*[a-zA-Z])+)([a-zA-Z\d]{10,30})$/m';
$str = '1eeeeeeeee333e
eeeeeeeee333e
2222222222222
622222222522
123456789012q';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);