import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:.*[a-zA-Z])+)([a-zA-Z\\d]{10,30})$";
final String string = "1eeeeeeeee333e\n"
+ "eeeeeeeee333e\n"
+ "2222222222222\n"
+ "622222222522\n"
+ "123456789012q";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}