re = /^(?=(?:.*[a-zA-Z])+)([a-zA-Z\d]{10,30})$/m
str = '1eeeeeeeee333e
eeeeeeeee333e
2222222222222
622222222522
123456789012q'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end