using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:.*[a-zA-Z])+)([a-zA-Z\d]{10,30})$";
string input = @"1eeeeeeeee333e
eeeeeeeee333e
2222222222222
622222222522
123456789012q";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}