# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<table(.(?!<\/table>))*//gm;t' <<< "<table>table</table>"