$re = '~<table(.(?!</table>))*~m';
$str = '<table>table</table>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;