re = /<table(.(?!<\/table>))*/m
str = '<table>table</table>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result