import re
regex = re.compile(r"<table(.(?!</table>))*", flags=re.MULTILINE)
test_str = "<table>table</table>"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)