const regex = new RegExp('<table(.(?!</table>))*', 'gm')
const str = `<table>table</table>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);