use strict;
my $str = '<table>table</table>';
my $regex = qr~<table(.(?!</table>))*~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";