#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/\*(?>[^*]*(?:\*+|\z(*ACCEPT)))+?/"
Local $sString = " abc /* hi */ def /* h*i */" & @CRLF & _
"" & @CRLF & _
"ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df" & @CRLF & _
"dfg dfg dfg " & @CRLF & _
"dfg dfg df" & @CRLF & _
"g df gdfg */" & @CRLF & _
"" & @CRLF & _
"ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df" & @CRLF & _
"dfg dfg dfg " & @CRLF & _
"dfg dfg df" & @CRLF & _
"g df gdfg "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")