const regex = new RegExp('/\\*(?>[^*]*(?:\\*+|\\z(*ACCEPT)))+?/', 'g')
const str = ` abc /* hi */ def /* h*i */
ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df
dfg dfg dfg
dfg dfg df
g df gdfg */
ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df
dfg dfg dfg
dfg dfg df
g df gdfg `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}