import Foundation
let pattern = #"/\*(?>[^*]*(?:\*+|\z(*ACCEPT)))+?/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
abc /* hi */ def /* h*i */
ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df
dfg dfg dfg
dfg dfg df
g df gdfg */
ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df
dfg dfg dfg
dfg dfg df
g df gdfg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)