$re = '~/\*(?>[^*]*(?:\*+|\z(*ACCEPT)))+?/~';
$str = ' abc /* hi */ def /* h*i */
ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df
dfg dfg dfg
dfg dfg df
g df gdfg */
ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df
dfg dfg dfg
dfg dfg df
g df gdfg ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);