re = /\/\*(?>[^*]*(?:\*+|\z(*ACCEPT)))+?\//
str = ' abc /* hi */ def /* h*i */
ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df
dfg dfg dfg
dfg dfg df
g df gdfg */
ghi /* dfg*df*g d *fd g*dfg**fdgdfgfdg dfg dfg fdg dfg df
dfg dfg dfg
dfg dfg df
g df gdfg '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end