# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=ab|cd|ef|gh) *}} *{{ *(?=ab|cd|ef|gh)/|/gm;t' <<< "{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{ghen web|url=tr.uc}}
machintrcd}} {{ab}} {{cd}}
{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}
{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}
machintruc {{ab}} {{cd}}
{{ab}} {{cd}} {{ef}} [https://truc.org truc]
{{mr}} Trucmuche"