import re
regex = re.compile(r"(?<=ab|cd|ef|gh) *}} *{{ *(?=ab|cd|ef|gh)", flags=re.MULTILINE)
test_str = ("{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{ghen web|url=tr.uc}}\n"
"machintrcd}} {{ab}} {{cd}}\n"
"{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}\n"
"{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}\n"
"machintruc {{ab}} {{cd}}\n"
"{{ab}} {{cd}} {{ef}} [https://truc.org truc]\n"
"{{mr}} Trucmuche")
subst = "|"
result = regex.sub(subst, test_str)
if result:
print(result)