using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=ab|cd|ef|gh) *}} *{{ *(?=ab|cd|ef|gh)";
string substitution = @"|";
string input = @"{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{ghen web|url=tr.uc}}
machintrcd}} {{ab}} {{cd}}
{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}
{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}
machintruc {{ab}} {{cd}}
{{ab}} {{cd}} {{ef}} [https://truc.org truc]
{{mr}} Trucmuche";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}