use strict;
my $str = '{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{ghen web|url=tr.uc}}
machintrcd}} {{ab}} {{cd}}
{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}
{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}
machintruc {{ab}} {{cd}}
{{ab}} {{cd}} {{ef}} [https://truc.org truc]
{{mr}} Trucmuche';
my $regex = qr/(?<=ab|cd|ef|gh) *}} *{{ *(?=ab|cd|ef|gh)/mp;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";