re = /(?<=ab|cd|ef|gh) *}} *{{ *(?=ab|cd|ef|gh)/m
str = '{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{ghen web|url=tr.uc}}
machintrcd}} {{ab}} {{cd}}
{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}
{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}
machintruc {{ab}} {{cd}}
{{ab}} {{cd}} {{ef}} [https://truc.org truc]
{{mr}} Trucmuche'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result