package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\\\/]|~\w~`)
var str = `test
test1/
test2\
/test3
\test4
~b~test5
test6~r~
~w~test7~t~
~r~test8 vv~w~
~r~test9 vv~w~/
~r~test10 vv~w~\
/~r~test11 vv~w~
\~r~test12 vv~w~`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}