const regex = /[\\\/]|~\w~/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\\\\\\/]|~\\w~', 'gm')
const str = `test
test1/
test2\\
/test3
\\test4
~b~test5
test6~r~
~w~test7~t~
~r~test8 vv~w~
~r~test9 vv~w~/
~r~test10 vv~w~\\
/~r~test11 vv~w~
\\~r~test12 vv~w~`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}