import Foundation
let pattern = #"[\\\/]|~\w~"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test
test1/
test2\
/test3
\test4
~b~test5
test6~r~
~w~test7~t~
~r~test8 vv~w~
~r~test9 vv~w~/
~r~test10 vv~w~\
/~r~test11 vv~w~
\~r~test12 vv~w~
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)