re = /[\\\/]|~\w~/m
str = 'test
test1/
test2\\
/test3
\\test4
~b~test5
test6~r~
~w~test7~t~
~r~test8 vv~w~
~r~test9 vv~w~/
~r~test10 vv~w~\\
/~r~test11 vv~w~
\\~r~test12 vv~w~'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end