import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\\\\\/]|~\\w~";
final String string = "test\n"
+ "test1/\n"
+ "test2\\\n"
+ "/test3\n"
+ "\\test4\n"
+ "~b~test5\n"
+ "test6~r~\n"
+ "~w~test7~t~\n"
+ "~r~test8 vv~w~\n"
+ "~r~test9 vv~w~/\n"
+ "~r~test10 vv~w~\\\n"
+ "/~r~test11 vv~w~\n"
+ "\\~r~test12 vv~w~";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}