# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\\\/]|~\w~"
test_str = ("test\n"
"test1/\n"
"test2\\\n"
"/test3\n"
"\\test4\n"
"~b~test5\n"
"test6~r~\n"
"~w~test7~t~\n"
"~r~test8 vv~w~\n"
"~r~test9 vv~w~/\n"
"~r~test10 vv~w~\\\n"
"/~r~test11 vv~w~\n"
"\\~r~test12 vv~w~")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.