using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(?:[^{}]|(?R))*\}";
string input = @"This is a funny text about stuff,
look at this product {""action"":""product"",""options"":{...}}.
More Text is to come and another JSON string
{""action"":""review"",""options"":{...}}";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}