package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)\{(?:[^{}]|(?R))*\}`)
var str = `This is a funny text about stuff,
look at this product {"action":"product","options":{...}}.
More Text is to come and another JSON string
{"action":"review","options":{...}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}