// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)\{(?:[^{}]|(?R))*\}").unwrap();
let string = "This is a funny text about stuff,
look at this product {\"action\":\"product\",\"options\":{...}}.
More Text is to come and another JSON string
{\"action\":\"review\",\"options\":{...}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}